rpm prepare for rac install on linux

there are the rpm information listed on note which you can get from below

Document 811306.1 RAC and Oracle Clusterware Best Practices and Starter Kit (Linux)

check out the example on oel4 x86_64,you need to install each needed rpm package to avoid the coming error msg.

—————————————————————————————————

64-Bit Required RPM's

Red Hat,Oracle] Enterprise Linux 4:
 
binutils-2.15.92.0.2-13.0.0.0.2.x86_64 (you can install binutils-2.15.92.0.2-18.x86_64.rpm from RHEL4 Update 3.)
 
compat-db-4.1.25-9.x86_64.rpm
 
compat-gcc-32-c++ (with Patch 5240469 to correct bad genoccish file. see Note WebIV:430526.1))
 
compat-libstdc++-33-3.2.3-47.3.x86_64.rpm
 
compat-libstdc++-33-3.2.3-47.3.i386.rpm 
 
control-center-2.8.0-12.x86_64.rpm
 
gcc-3.4.3-47.x86_64.rpm
 
gcc-c++-3.4.3-47.x86_64.rpm   
 
glibc-2.3.4-2.9.x86_64.rpm   
 
glibc-2.3.4-2.9.i386.rpm   
 
glibc-common-2.3.4-2.9.x86_64.rpm   
 
glibc-devel-2.3.4-2.9.x86_64.rpm   
 
glibc-devel-2.3.4-2.9.i386.rpm   
 
glibc-headers-2.3.4-2.9.x86_64.rpm   
 
glibc-kernheaders-2.4-9.1.87.x86_64.rpm   
 
gnome-libs-1.4.1.2.90-44.1.x86_64
 
libaio-0.3.103-3.i386.rpm
 
libaio-0.3.103-3.x86_64.rpm   
 
libgcc-3.4.3-9.EL4
 
libstdc++-3.4.3-22.1.x86_64   
 
libstdc++-devel-3.4.3-22.1.x86_64   
 
make-3.80-5.x86_64.rpm
 
pdksh-5.2.14-30.x86_64.rpm   
 
sysstat-5.0.5-1.x86_64.rpm   
 
util-linux-2.12a-16.EL4.23.x86_64 (for raw devices)   
 
xorg-x11-deprecated-libs-6.8.1-23
 
xscreensaver-4.18-5.rhel4.2.x86_64.rpm   
 

——————————————————————————–

it's quite easy to find the details, you need both x86 and x86_64 in some rpm packs